Mysql 5.6 导出的带特殊编的数据如何成功导入低版本的Mysql 5.5中

分类栏目:数据库

发布于 暂无评论

最近有几个项目之前将数据库托管在了阿里云RDS上的Mysql 5.6里边,大家都知道阿里云自带的Mysql管理软件不是phpmyadmin而是DMS 3.0,功能虽然强大,但是总感觉用户体验不够好,尤其是批量操作的时候很奇怪的体验,然后又遇到一个新问题,从DMS里边导出的SQL文件,直接导入WDCP的Mysql 5.5的时候,提示一堆错误,无论如何修正都无法正确导入,于是想到了可能是Mysql版本不同导致的问题,于是一番摸索以后通过以下简单教程做一下说明如何解决这个问题:

在wordpress后台

搜索 UpdraftPlus Backup 下载wordpress 插件 updraftplus wordpress backup plugin 安装激活


current status -- backup now


include the database in the back  选择备份数据库

include any files in the back   选择备份文件


existing backup -- download to you computer--database



下载文件 ,手工修改文件格式为.sql


将所有的utf8mb4_unicode_520_ci 改为 utf8mb4_unicode_ci 否则会导致编码错误无法导入成功